站点图标 陌路寒暄

c#随机数的产生与输出

c#随机数的产生与输出

时间: 1ms        内存:128M

描述:

编写一个实例方法Method01。该方法使用Random类随机产生n个3位数字(如636)的随机正整数,并把产生的随机数存入数组中并输出该数组int num= Convert.ToInt32(Console.ReadLine());
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        {
int num= Convert.ToInt32(Console.ReadLine());
Program.Method01(num);

        }
/*
在下面填写代码
*/

    }
}

输入:

n

输出:

随机产生的数组

示例输入:

3

示例输出:

636
555
545

提示:

参考答案(内存最优[1120]):

#include <stdio.h>
#include <math.h>
int  main()
{
    int n,i;
    scanf("%d",&n);
    for(i=0;i<n;i++)
        printf("%d\n",111);
    return 0;
}

参考答案(时间最优[1]):

#include<stdio.h>
#include<time.h>
#include<stdlib.h>

int main()
{
    srand(time(0));
    int n;
    scanf("%d",&n);
    int i;
    for(i=1;i<=n;++i) printf("%d\n",rand()%800+100);
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版