站点图标 陌路寒暄

动态规划基础题目之数字三角形

动态规划基础题目之数字三角形

时间: 1ms        内存:64M

描述:

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入:

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

输出:

Your program is to write to standard output. The highest sum is written as an integer.

示例输入:

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

示例输出:

30

提示:

参考答案(内存最优[1092]):

#include<stdio.h>
#include<malloc.h>
int main()
{
    int n,a[100][100],i,j;
    scanf("%d",&n);
    for(i=0; i<n; ++i)
    {
        for(j=0; j<=i; ++j)
        {
            scanf("%d",&a[i][j]);
        }
    }
    for(i=n-1; i>1; --i)
    {
        for(j=0; j<i; ++j)
        {
          a[i-1][j]+=(a[i][j]>a[i][j+1])?a[i][j]:a[i][j+1];
                }
    }
    printf("%d",(a[0][0]+((a[1][0]>a[1][1])?a[1][0]:a[1][1])));
    return 0;
}

参考答案(时间最优[0]):

#include <iostream>
#include <algorithm>
using namespace std;
#define MAX 101
int D[MAX][MAX];
int n;
int maxSum[MAX][MAX];
int main()
{
    int i,j;
    cin >> n;
    for(i=1; i<=n; i++)   for(j=1; j<=i; j++)        cin >> D[i][j];
    for( int i = 1; i <= n; ++ i )
        maxSum[n][i] = D[n][i];
    for( int i = n-1; i>= 1;  --i )
        for( int j = 1; j <= i; ++j )
            maxSum[i][j] =    max(maxSum[i+1][j],maxSum[i+1][j+1]) + D[i][j]    ;
    cout << maxSum[1][1] << endl;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版