站点图标 陌路寒暄

闰年判断

闰年判断

时间: 1ms        内存:128M

描述:

定义一个函数leapyear,函数声明如下:


int leapyear(int n);   
//函数声明,如果参数n是闰年返回1,不是闰年返回0


在下面代码的基础上完成,提交时只提交leapyear的函数定义


#include <iostream>
using namespace std;
 
int leapyear(int n); //函数声明,如果参数n是闰年返回1,不是闰年返回0
 
int main()
{
   int year;
   cin>>year;  
   if( leapyear(year)==1 )
      cout<<"leapyear"<<endl;
   else
      cout<<"not leapyear"<<endl;   
   return 0;
}

输入:

输出:

如果输入的年是闰年输出leapyear,如果不是闰年输出not leapyear

示例输入:

2000

示例输出:

leapyear

提示:

参考答案(内存最优[1092]):

#include<stdio.h>
int main()
{
  int n;
  scanf("%d",&n);
  if((n%4==0&&n%100!=0)||n%400==0)
	  printf("leapyear");
  else printf("not leapyear");
}

参考答案(时间最优[0]):


#include <iostream>
using namespace std;
 
int leapyear(int n); //函数声明,如果参数n是闰年返回1,不是闰年返回0
 
int main()
{
   int year;
   cin>>year;   
   if(leapyear(year)==1)
      cout<<"leapyear"<<endl;
   else
      cout<<"not leapyear"<<endl;    
   return 0;
}


int leapyear(int n) //函数定义,如果参数n是闰年返回1,不是闰年返回0
{
    if((n%4==0&&n%100!=0)||n%400==0)
		return 1;
	else
		return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版