站点图标 陌路寒暄

B 虚拟继承(虚基类)-沙发床(改错题)

B 虚拟继承(虚基类)-沙发床(改错题)

时间: 1ms        内存:128M

描述:

 有一种特殊的床,既能当床(Bed)用又能当沙发(Sofa)用,所以叫沙发床(SleeperSofa)。

同时床和沙发又是一种特殊的家具(Furniture),具有一切家具的特性。

利用虚拟继承(虚基类)建立一个类的多重继承,沙发床继承了床和沙发的特性。

下面的程序中,在begin到end部分存在语法错误。请改正错误,使程序按下面输入输出的规定运行。

注意:只提交修改过的begin到end部分的代码。

#include <iostream>
using namespace std;

//家具类Furniture
class Furniture
{
public:
Furniture(double w)
{ weight=w; }
void display()
{
cout<<"weight:"<<weight<<endl;
}
protected:
double weight; //家具重量
};

//******************** begin ********************
//床类Bed
class Bed: public Furniture
{
public:
Bed(double we,double l,double wi):Furniture(we),length(l),width(wi){}
void display()
{
cout<<"length:"<<length<<endl;
cout<<"width:"<<width<<endl;
}
protected:
double length; //床的长
double width; //床的宽
};

//沙发类Sofa
class Sofa: public Furniture
{ public:
Sofa(double w,double h):Furniture(w),height(h){}
void display()
{
cout<<"height:"<<height<<endl;
}
protected:
double height; //沙发的高度
};

//沙发床
class SleeperSofa:public Bed, public Sofa
{public:
SleeperSofa(double we,double l,double wi,double h):Bed(we,l,wi),Sofa(we,h){ }
void display()
{
cout<<"weight:"<<weight<<endl;
Bed::display();
Sofa::display();
}
};

//********************* end ********************

int main()
{
double weight,length,width,height;
cin>>weight>>length>>width>>height;

SleeperSofa ss(weight,length,width,height);
ss.display();

return 0;
}

输入:

依次输入沙发床的重量、长、宽、高  

输出:

依次输出沙发床的重量、长、宽、高

示例输入:

200 1.8 1.5 1.2

示例输出:

weight:200
length:1.8
width:1.5
height:1.2

提示:

参考答案(内存最优[1092]):

#include <stdio.h>
#include <stdlib.h>
#include<math.h>
int main()
{
    float a,b,c,d;
    scanf("%f%f%f%f",&a,&b,&c,&d);
    printf("weight:%.0f\nlength:%.1f\nwidth:%.1f\nheight:%.1f",a,b,c,d);
    return 0;
}

参考答案(时间最优[0]):


#include <iostream>
using namespace std;

//家具类Furniture
class Furniture
{
  public:
     Furniture(double w)
      { weight=w; }
	 void display()
	 {
		 cout<<"weight:"<<weight<<endl;
	 }
  protected:
    double weight; //家具重量
};
//床类Bed
class Bed:virtual public Furniture
{
  public:
	  Bed(double we,double l,double wi):Furniture(we),length(l),width(wi){}
	  void display()
	  {   
		  cout<<"length:"<<length<<endl;
		  cout<<"width:"<<width<<endl;
	  }
  protected:
     double length; //床的长
     double width; //床的宽     
};

//沙发类Sofa
class Sofa:virtual public Furniture
{  public:
      Sofa(double w,double h):Furniture(w),height(h){}
	  void display()
	  {
	     cout<<"height:"<<height<<endl;
	  }
   protected:
      double height; //沙发的高度  
};

//沙发床
class SleeperSofa:public Bed, public Sofa
{public: 
  SleeperSofa(double we,double l,double wi,double h):Furniture(we),Bed(we,l,wi),Sofa(we,h){ }
  void display()
  { 
	  cout<<"weight:"<<weight<<endl;
	  Bed::display();
	  Sofa::display();
  }
};
int main()
{
  double weight,length,width,height;
  cin>>weight>>length>>width>>height;

  SleeperSofa ss(weight,length,width,height);
  ss.display();
  
  return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版