站点图标 陌路寒暄

Longest Ordered Subsequence

Longest Ordered Subsequence

时间: 1ms        内存:64M

描述:

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, the sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e.g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences of this sequence are of length 4, e.g., (1, 3, 5, 8). Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

输入:

The first line of input contains the length of sequence N (1 <= N <= 1000). The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces.

输出:

Output must contain a single integer - the length of the longest ordered subsequence of the given sequence.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

示例输入:

1

7
1 7 3 5 9 4 8

示例输出:

4

提示:

参考答案(内存最优[748]):

#include<stdio.h>  
int main()  
{
	int a[1010];
	int m,n,i,j,x,max=0;
	scanf("%d",&m);
	while(m--)
	{
		scanf("%d",&n);  
		for (i=0;i<n;i++)
		{
			a[i]=10001;  
			scanf("%d",&x);  
			for (j=0;a[j]<x;j++);  
			a[j]=x;
			if (max<j+1)
				max=j+1;
		}
		printf("%d\n",max);
	}
	return 0; 
}

参考答案(时间最优[0]):

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <map>
using namespace std;
int main()
{
    int t,cnt,n,i,j;
    cin>>t;
    for(cnt=0;cnt<t;cnt++)
    {
        int a[1005],dp[1005];
        cin>>n;
        for(i=0;i<n;i++)
            cin>>a[i];
        dp[0]=1;
        int ans=1;
        for(i=1;i<n;i++)
        {
            int m=0;
            for(j=0;j<i;j++)
            {
                if(dp[j]>m&&a[j]<a[i])
                {
                    m=dp[j];
                }
            }
            dp[i]=m+1;
            if(dp[i]>ans)
                ans=dp[i];
        }
        cout<<ans<<endl;
        if(cnt!=t-1)cout<<endl;
    }
    return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版