站点图标 陌路寒暄

The Hardest Problem Ever

The Hardest Problem Ever

时间: 1ms        内存:64M

描述:

Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked. You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite: Cipher text A B C D E F G H I J K L M N O P Q R S T U V W X Y Z Plain text V W X Y Z A B C D E F G H I J K L M N O P Q R S T U Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.

输入:

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase. A single data set has 3 components: Start line - A single line, "START" Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar End line - A single line, "END" Following the final data set will be a single line, "ENDOFINPUT".

输出:

For each data set, there will be exactly one line of output. This is the original message by Caesar.

示例输入:

START
NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX
END
START
N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ
END
START
IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ
END
ENDOFINPUT

示例输出:

IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES
I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME
DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE

提示:

参考答案(内存最优[752]):

#include <stdio.h>
#include <string.h>
int main()
{
    int i,j;
    char a[110],b[20];
    while(gets(b))
    {
        if(strcmp(b,"ENDOFINPUT")==0)
            break;
        gets(a);
        gets(b);
        for(i=0;a[i]!=0;i++)
            if(a[i]>='A'&&a[i]<='E')
                printf("%c",a[i]+=21);
            else
                if(a[i]>='F'&&a[i]<='Z')
                    printf("%c",a[i]-=5);
                else
                    printf("%c",a[i]);
            printf("\n");
    }
    return 0;
}

参考答案(时间最优[0]):

#include <stdio.h>
#include <string.h>
int main()
{
    int i,j;
    char a[110],b[20];
    while(gets(b))
    {
        if(strcmp(b,"ENDOFINPUT")==0)
            break;
        gets(a);
        gets(b);
        for(i=0;a[i]!=0;i++)
            if(a[i]>='A'&&a[i]<='E')
                printf("%c",a[i]+=21);
            else
                if(a[i]>='F'&&a[i]<='Z')
                    printf("%c",a[i]-=5);
                else
                    printf("%c",a[i]);
            printf("\n");
    }
    return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版