站点图标 陌路寒暄

Beat the Spread!

Beat the Spread!

时间: 1ms        内存:64M

描述:

Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores. Given the winning numbers for each type of bet, can you deduce the final scores?

输入:

The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.

输出:

For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.

示例输入:

2
40 20
20 40

示例输出:

30 10
impossible

提示:

参考答案(内存最优[748]):

#include<stdio.h>
#include<math.h> 
int main() 
{ 
    int a,b,n,x,y;
    scanf("%d",&n);
    while(n--){
      scanf("%d %d",&a,&b);
      if(a<b||(a+b)%2!=0||(abs(a-b))%2!=0){
        printf("impossible\n");
        continue;
      }
      else
        printf("%d %d\n",(a+b)/2,(abs(a-b)/2));
    } 
    return 0; 
}

参考答案(时间最优[0]):

#include<stdio.h>

int main()
{
    int N;
    scanf("%d",&N);
    while(N--)
    {
        int sum,dif;
        scanf("%d%d",&sum,&dif);
        if((sum-dif)<0)
            printf("impossible\n");
        else if((sum-dif)%2!=0)
            printf("impossible\n");
        else
            printf("%d %d\n",(sum+dif)/2,(sum-dif)/2);
    }
    return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版