站点图标 陌路寒暄

Electrical Outlets

Electrical Outlets

时间: 1ms        内存:64M

描述:

Roy has just moved into a new apartment.Well, actually the apartment itself is not very new, even dating back to the days before people had electricity in their houses. Because of this, Roy??s apartment has only one single wall outlet, so Roy can only power one of his electrical appliances at a time.

Roy likes to watch TV as he works on his computer, and to listen to his HiFi system (on high volume) while he vacuums, so using just the single outlet is not an option. Actually, he wants to have all his appliances connected to a powered outlet, all the time. The answer, of course, is power strips, and Roy has some old ones that he used in his old apartment. However, that apartment had many more wall outlets, so he is not sure whether his power strips will provide him with enough outlets now.

Your task is to help Roy compute how many appliances he can provide with electricity, given a set of power strips. Note that without any power strips, Roy can power one single appliance through the wall outlet. Also, remember that a power strip has to be powered itself to be of any use.

输入:

Input vill start with a single integer 1 ≤ N ≤ 20, indicating the number of test cases to follow. Then follow N lines, each describing a test case. Each test case starts with an integer 1 ≤ K ≤ 10, indicating the number of power strips in the test case. Then follow, on the same line, K integers separated by single spaces, O1O2...OK , where 2 ≤ Oi ≤ 10, indicating the number of outlets in each power strip.

输出:

Output one line per test case, with the maximum number of appliances that can be powered.

示例输入:

3
3 2 3 4
10 4 4 4 4 4 4 4 4 4 4
4 10 10 10 10

示例输出:

7
31
37

提示:

参考答案(内存最优[748]):

#include<stdio.h>
int main() 
{ 
    int n,x,t,sum,r;
    scanf("%d",&n);
    while(n--){
       sum=0;
       scanf("%d",&x);
       r=x-1;
       while(x--){
         scanf("%d",&t);
         sum+=t;
       }
       printf("%d\n",sum-r);
    }
    return 0; 
}

参考答案(时间最优[0]):

#include <stdio.h>
int main()
{
    int T,n,s[11],t;
    scanf("%d",&T);
    while(T--)
    {
        int count=1;
        scanf("%d",&n);
        for(int i=0;i<n;++i)
        {
            scanf("%d",&t);
            count+=t;
        }
        count-=n;
        printf("%d\n",count);
    }
    return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版