站点图标 陌路寒暄

Windows Message Queue

Windows Message Queue

时间: 1ms        内存:64M

描述:

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

输入:

There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

输出:

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

示例输入:

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

示例输出:

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

提示:

参考答案(内存最优[752]):

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
typedef struct node
{
    char ch[1000];
    int data;
    int pri;
    struct node *next;
} node;
int main()
{
    char c[50];
    node *head=NULL;
    while(scanf("%s",c)!=EOF)
    {
        if(!strcmp(c,"GET"))
        {
            if(head==NULL)
                printf("EMPTY QUEUE!\n");
            else
            {
                printf("%s %d\n",head->ch,head->data);
                node *n;
                n=head;
                head=head->next;
                free(n);
            }
        }
        else
        {
            node *t;
            t=(node *)malloc(sizeof(node));
            scanf("%s%d%d",t->ch,&(t->data),&(t->pri));
            t->next = NULL;
            if(head==NULL)
            {
                head=t;
            }
            else
            {
                node *tt;
                tt=head;
                while(tt->next!=NULL && tt->next->pri <= t->pri)
                    tt=tt->next;
                if(head->pri>t->pri)
                {
                    t->next=head;
                    head=t;
                }
                else
                {
                    t->next=tt->next;
                    tt->next=t;
                }
            }
        }
    }
    return 1;
}

参考答案(时间最优[0]):

#include <queue>
#include <cstdio>
#include <cstring>
#include <string>
#include <iostream>
using namespace std;
class ss
{
    public:
    int data;
    string name;
    int stand;
    int ct;
    bool operator<(ss b)const
    {
        if(stand!=b.stand)
        return stand>b.stand;
        return ct>b.ct;
    }
};
int main()
{
    char c[5];
    priority_queue<ss> q;
    int count=0;
    while(~scanf("%s",c))
    {
        if(strcmp(c,"PUT")==0)
        {
            ss t;
            cin>>t.name;
            scanf("%d%d",&t.data,&t.stand);
            t.ct=count++;
            q.push(t);
        }
        else
        {
            if(q.empty())printf("EMPTY QUEUE!\n");
            else
            {
                cout<<q.top().name;
                printf(" %d\n",q.top().data);
                q.pop();
            }
        }
    }
    return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版