站点图标 陌路寒暄

Digital Roots

Digital Roots

时间: 1ms        内存:64M

描述:

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit. For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

输入:

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

输出:

For each integer in the input, output its digital root on a separate line of the output.

示例输入:

24
39
0

示例输出:

6
3

提示:

参考答案(内存最优[752]):

#include <stdio.h>
#include <string.h>
int f(int n)
{
if (n<=9)
{ 
return n; 
}
int r=0;
while(n>0)
{
   r+=n%10;
   n/=10;
}
return f(r);
}
int main()
{
char s[1024];
int n,i;
while(scanf("%s",s)&&strcmp(s,"0")!=0)
{
   n=0;
   for(i=0;s[i];i++)
   {
    n+=s[i]-'0';
   }
   printf("%d\n",f(n));
}
return 0;
}

参考答案(时间最优[0]):

#include <stdio.h>
#include <string.h>
int f(int n)
{
if (n<=9)
{ 
return n; 
}
int r=0;
while(n>0)
{
   r+=n%10;
   n/=10;
}
return f(r);
}
int main()
{
char s[1024];
int n,i;
while(scanf("%s",s)&&strcmp(s,"0")!=0)
{
   n=0;
   for(i=0;s[i];i++)
   {
    n+=s[i]-'0';
   }
   printf("%d\n",f(n));
}
return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版