站点图标 陌路寒暄

Look and Say

Look and Say

时间: 1ms        内存:64M

描述:

The look and say sequence is defined as follows. Start with any string of digits as the first element in the sequence. Each subsequent element is defined from the previous one by "verbally" describing the previous element. For example, the string 122344111 can be described as "one 1, two 2's, one 3, two 4's, three 1's". Therefore, the element that comes after 122344111 in the sequence is 1122132431. Similarly, the string 101 comes after 1111111111. Notice that it is generally not possible to uniquely identify the previous element of a particular element. For example, a string of 112213243 1's also yields 1122132431 as the next element.

输入:

The input consists of a number of cases. The first line gives the number of cases to follow. Each case consists of a line of up to 1000 digits.

输出:

For each test case, print the string that follows the given string.

示例输入:

3
122344111
1111111111
12345

示例输出:

1122132431
101
1112131415

提示:

参考答案(内存最优[752]):

#include"stdio.h"
#include"string.h"
int main()
{
	char str[1500]={0};
	char a[1500]={0};
	int n,i,j,k,c,b,d;
	scanf("%d",&n);
	getchar();
	while(n--)
	{
		b=0;
		gets(str);
		d=strlen(str);
		for(i=0;str[i]!='\0';i++)
		{
			if(str[i]==32)
			{
				b=1;
				break;
			}
		}
		if(b==1)
		{
			k=0;
			for(i=0;i<=d;i++)
			{
				if(str[i]!=32)
				{
					a[k]=str[i];
					k++;
				}
			}
			printf("%s",a);
		}
		else
		{
			for(i=0;i<d;i=j)
			{
				c=1;
				for(j=i+1;j<d;j++)
				{
					if(str[i]==str[j])
						c++;
					else
						break;
				}
				printf("%d%c",c,str[i]);
			}
		}
		if(n>0)
			printf("\n");	
	}
	return 0;
}

参考答案(时间最优[56]):

#include"stdio.h"
#include"string.h"
int main()
{
	char str[1500]={0};
	char a[1500]={0};
	int n,i,j,k,c,b,d;
	scanf("%d",&n);
	getchar();
	while(n--)
	{
		b=0;
		gets(str);
		d=strlen(str);
		for(i=0;str[i]!='\0';i++)
		{
			if(str[i]==32)
			{
				b=1;
				break;
			}
		}
		if(b==1)
		{
			k=0;
			for(i=0;i<=d;i++)
			{
				if(str[i]!=32)
				{
					a[k]=str[i];
					k++;
				}
			}
			printf("%s",a);
		}
		else
		{
			for(i=0;i<d;i=j)
			{
				c=1;
				for(j=i+1;j<d;j++)
				{
					if(str[i]==str[j])
						c++;
					else
						break;
				}
				printf("%d%c",c,str[i]);
			}
		}
		if(n>0)
			printf("\n");	
	}
	return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版