站点图标 陌路寒暄

Vito

Vito

时间: 1ms        内存:64M

描述:

The famous gangster Vito Deadstone is moving to New York. He has a very big family there, all of them living on Lamafia Avenue. Since he will visit all his relatives very often, he wants to find a house close to them. Indeed, Vito wants to minimize the total distance to all of his relatives and has blackmailed you to write a program that solves his problem.

输入:

The input consists of several test cases. The first line contains the number of test cases. For each test case you will be given the integer number of relatives r (0 < r < 500) and the street numbers (also integers) s1, s2,..., si,..., sr where they live (0 < si < 30, 000). Note that several relatives might live at the same street number.

输出:

For each test case, your program must write the minimal sum of distances from the optimal Vito's house to each one of his relatives. The distance between two street numbers si and sj is dij = | si - sj|.

示例输入:

2
2 2 4 
3 2 4 6

示例输出:

2
4

提示:

参考答案(内存最优[752]):

#include<stdio.h>
#include<math.h>
void sort(int a[],int n)
{
	int i,j,t;
	for(i=0;i<n-1;i++)
		for(j=0;j<n-1-i;j++)
			if(a[j]>a[j+1])
			{
				t=a[j];
				a[j]=a[j+1];
				a[j+1]=t;
			}
}
int main()
{
	int testnum,relativenum,sum,p,d,i,j;
	int relative[500];
	
	scanf("%d",&testnum);
	for(i=0;i<testnum;i++)
	{
		sum=0;
		scanf("%d",&relativenum);
		for(j=0;j<relativenum;j++)
		{
			scanf("%d",&relative[j]);
		}
		sort(relative,relativenum);
		p=relative[(relativenum-1)/2];
		d=0;
		for(j=0;j<relativenum;j++)
			d+=abs(p-relative[j]);
		printf("%d\n",d);	
	}
}

参考答案(时间最优[0]):

#include <stdio.h>
#include <string.h>
#include <ctype.h>
#include <algorithm>
using namespace std;
int t, r, s[505], mid, sum;
int main()
{
    scanf("%d", &t);
    while (t --)
    {
        sum = 0;
        scanf("%d", &r);
        for (int i = 0; i < r; i ++)
            scanf("%d", &s[i]);
        sort(s, s + r);
        mid = s[r / 2];
        for (int i = 0; i < r ; i ++)
        {
            sum += abs(s[i] - mid);
        }
        printf("%d\n", sum);
    }
    return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版