站点图标 陌路寒暄

The Trip

The Trip

时间: 1ms        内存:64M

描述:

The Trip

A group of students are members of a club that travels annually to different locations. Their destinations in the past have included Indianapolis, Phoenix, Nashville, Philadelphia, San Jose, and Atlanta. This spring they are planning a trip to Eindhoven.

The group agrees in advance to share expenses equally, but it is not practical to share every expense as it occurs. Thus individuals in the group pay for particular things, such as meals, hotels, taxi rides, and plane tickets. After the trip, each student's expenses are tallied and money is exchanged so that the net cost to each is the same, to within one cent. In the past, this money exchange has been tedious and time consuming. Your job is to compute, from a list of expenses, the minimum amount of money that must change hands in order to equalize (within one cent) all the students' costs.

输入:

Standard input will contain the information for several trips. Each trip consists of a line containing a positive integer n denoting the number of students on the trip. This is followed by n lines of input, each containing the amount spent by a student in dollars and cents. There are no more than 1000 students and no student spent more than $10,000.00. A single line containing 0 follows the information for the last trip.

输出:

For each trip, output a line stating the total amount of money, in dollars and cents, that must be exchanged to equalize the students' costs.

示例输入:

3
10.00
20.00
30.00
4
15.00
15.01
3.00
3.01
0

示例输出:

$10.00
$11.99

提示:

参考答案(内存最优[752]):

#include <stdio.h>

int cents[1000];

main(){
   int i,j,k,m,n;
   int sum,ave,ove,bal;
   int nove;
   double x;

   for (;;){
      scanf("%d",&n);
      if (!n) break;
      sum = 0;
      for (i=0;i<n;i++){
         scanf("%lf",&x);
         cents[i] = 100 * x + 0.1;
         sum += cents[i];
      }
      ave = sum/n;
      ove = 0;
      nove = 0;
      for (i=0;i<n;i++) if (cents[i] > ave) {
         nove++;
         ove += cents[i]-ave;
      }
      if (nove >= sum%n) bal = ove - sum%n;
      else bal = ove - nove;
      printf("$%0.2lf\n",(double)bal/100);
   }
}

参考答案(时间最优[4]):

#include <stdio.h>
#define maxsize 1000
int main (int argc, const char * argv[])
{

    long numOfStudents;
    double total;
    double exchange;
    double equalizedAmount;
    double diff;
    double negativeSum;
    double positiveSum;
    double amountSpent[maxsize];
    int i;
    while(scanf("%ld", &numOfStudents), numOfStudents)
    {

        total =0;
        negativeSum = 0;
        positiveSum = 0;
        for (i = 0; i < numOfStudents; i++)
        {
            scanf("%lf", &amountSpent[i]);
            total += amountSpent[i];
        }
        getchar();
        equalizedAmount = total / numOfStudents;
        for (i = 0; i < numOfStudents; i++)
        {

            diff = (double) (long) ((amountSpent[i] - equalizedAmount) * 100.0) / 100.0;
            if (diff < 0)
            {
                negativeSum += diff;
            }
            else
            {
                positiveSum += diff;
            }
        }
        exchange = (-negativeSum > positiveSum)? -negativeSum : positiveSum;
        printf("$%.2lf\n", exchange);
    }

    return 0;

}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版