站点图标 陌路寒暄

Pseudoprime numbers

Pseudoprime numbers

时间: 1ms        内存:128M

描述:

Fermat's theorem states that for any prime number p and for any integer a > 1, ap == a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1,000,000,000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a. For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

输入:

输出:

示例输入:

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

示例输出:

no
no
yes
no
yes
yes

提示:

参考答案(内存最优[752]):

#include <stdio.h>

int isprime(long long p)
{
    long long i;
    for(i = 2; i*i <= p; i++)
    {
        if(p%i == 0) return 0;
    }
    return 1;
}

int main()
{
    long long p, a, ap, pp, aa;
    while(1)
    {
        scanf("%lld %lld", &p, &a);
/*        scanf("%I64d %I64d", &p, &a);*/
        if(p == 0) break;
        if(isprime(p))
        {
            puts("no");
            continue;
        }
        ap = 1;
        pp = p;
        aa = a;
        while(pp)
        {
            if(pp&1) ap*= aa;
            ap %= p;
            aa = (aa*aa)%p;
            pp >>= 1;
        }
/*        printf("%lld %lld\n", ap%p, a);*/
        if(ap%p == a) puts("yes");
        else puts("no");
    }
}


参考答案(时间最优[0]):

#include<stdio.h>
int pp(int a)
{
    int i;
    for(i=2; i*i<=a; i++)
    if(a%i==0) return 0;
    return 1;
}
int mod(long x,long n,long m)
{
    long a,r=1;
    a=x;
    while(n)
    {
        if(n&1)
            r=r*x%m;
        x=x*x%m;
        n>>=1;
    }
    return r==a?1:0;
}
int main()
{
    int a,p;
    while(~scanf("%d%d",&p,&a)&&a|p)
    {
        if(!pp(p)&&mod(a,p,p))
            printf("yes\n");
        else printf("no\n");
    }
    return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版