站点图标 陌路寒暄

Problem E - Ones

Problem E - Ones

时间: 1ms        内存:128M

描述:

Given any integer 0 <= n <= 10000 not divisible by 2 or 5, some multiple of n is a number which in decimal notation is a sequence of 1's. How many digits are in the smallest such a multiple of n?

输入:

输出:

示例输入:

3 
7 
9901

示例输出:

3
6
12

提示:

参考答案(内存最优[920]):

#include <stdio.h>

main(){
   int n,rem,digs;
   while (1 == scanf("%d",&n)) {
      for (rem=digs=1;rem;digs++) rem = (rem*10+1) % n;
      printf("%d\n",digs);
   }
}

参考答案(时间最优[0]):

#include <stdio.h>

main(){
   int n,rem,digs;
   while (1 == scanf("%d",&n)) {
      for (rem=digs=1;rem;digs++) rem = (rem*10+1) % n;
      printf("%d\n",digs);
   }
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版