站点图标 陌路寒暄

Problem A: Gopher II

Problem A: Gopher II

时间: 1ms        内存:128M

描述:

Problem A: Gopher II

The gopher family, having averted the canine threat, must face a new predator.

The are n gophers and m gopher holes, each at distinct (x, y) coordinates. A hawk arrives and if a gopher does not reach a hole in s seconds it is vulnerable to being eaten. A hole can save at most one gopher. All the gophers run at the same velocity v. The gopher family needs an escape strategy that minimizes the number of vulnerable gophers.

The input contains several cases. The first line of each case contains four positive integers less than 100: n, m, s, and v. The next n lines give the coordinates of the gophers; the following m lines give the coordinates of the gopher holes. All distances are in metres; all times are in seconds; all velocities are in metres per second.

Output consists of a single line for each case, giving the number of vulnerable gophers.

输入:

输出:

示例输入:

2 2 5 10
1.0 1.0
2.0 2.0
100.0 100.0
20.0 20.0

示例输出:

1

提示:

参考答案(内存最优[760]):

#include <stdio.h>

double x[100][10];  double s;

main(){
   int i,j,k,n;
   while (2 == scanf("%d%d",&k,&n)){
      k++;
      for (i=0;i<n;i++) for (j=0;j<k;j++) x[i][j] = 0;
      for (i=0;i<k;i++) x[0][i] = 100.0/k;
      for (i=1;i<n;i++) {
         for (j=0;j<k;j++) x[i][j] += x[i-1][j]/k;
         for (j=1;j<k;j++) x[i][j] += x[i-1][j-1]/k;
         for (j=0;j<k-1;j++) x[i][j] += x[i-1][j+1]/k;
      }
      for (s=i=0;i<k;i++) s += x[n-1][i];
      printf("%0.5lf\n",s);
   }
}

参考答案(时间最优[8]):

#include <stdio.h>

double x[100][10];  double s;

main(){
   int i,j,k,n;
   while (2 == scanf("%d%d",&k,&n)){
      k++;
      for (i=0;i<n;i++) for (j=0;j<k;j++) x[i][j] = 0;
      for (i=0;i<k;i++) x[0][i] = 100.0/k;
      for (i=1;i<n;i++) {
         for (j=0;j<k;j++) x[i][j] += x[i-1][j]/k;
         for (j=1;j<k;j++) x[i][j] += x[i-1][j-1]/k;
         for (j=0;j<k-1;j++) x[i][j] += x[i-1][j+1]/k;
      }
      for (s=i=0;i<k;i++) s += x[n-1][i];
      printf("%0.5lf\n",s);
   }
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版