站点图标 陌路寒暄

The 3n + 1 problem

The 3n + 1 problem

时间: 1ms        内存:64M

描述:

Consider the following algorithm to generate a sequence of numbers. Start with an integer n. If n is even, divide by 2. If n is odd, multiply by 3 and add 1. Repeat this process with the new value of n, terminating when n = 1. For example, the following sequence of numbers will be generated for n = 22:
22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1
It is conjectured (but not yet proven) that this algorithm will terminate at n = 1 for every integer n. Still, the conjecture holds for all integers up to at least 1, 000, 000.

For an input n, the cycle-length of n is the number of numbers generated up to and including the 1. In the example above, the cycle length of 22 is 16. Given any two numbers i and j, you are to determine the maximum cycle length over all numbers between i and j, including both endpoints.

输入:

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

输出:

For each pair of input integers i and j, output i, j in the same order in which they appeared in the input and then the maximum cycle length for integers between and including i and j. These three numbers should be separated by one space, with all three numbers on one line and with one line of output for each line of input.

示例输入:

1 10
100 200
201 210
900 1000

示例输出:

1 10 20
100 200 125
201 210 89
900 1000 174

提示:

参考答案(内存最优[748]):

#include <stdio.h>
int F(int i);
int main()
{
	int a,b,i,temp=0,temp1,temp2,a1,a2;
	while(scanf("%d %d",&a,&b)==2)
	{
                  a1=a;
                  a2=b;
                  if(a>b)
                  {
                      temp2=a;
                      a=b;
                      b=temp2;
                  }
		for(i=a;i<=b;i++)
		{
			temp1=F(i);
			//printf("%d\n",temp1);
			if(temp<temp1)
				temp=temp1;
		}
		printf("%d %d %d\n",a1,a2,temp);
		temp=0;
	}
}

int F(int i)
{
	int temp=i,j=1;
	while(1)
	{
		if(temp==1)
			return j;
		if(temp%2==0)
		{
			temp=temp/2;
		}
		else
		{
			temp=temp*3+1;
		}
		j++;
	}
}

参考答案(时间最优[0]):

#include"stdio.h"
int a[105][105];
char s[105][105];
int main()
{
	int m,n,i,j,c=0;
	while(scanf("%d %d",&n,&m)==2&&(n||m))
	{
		getchar();
		for(i=0;i<=n;i++)
			for(j=0;j<=n;j++)
				a[i][j]=0;
		c++;
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=m;j++)
			{
				scanf("%c",&s[i][j]);
			if(s[i][j]=='*')
			{
				a[i][j]=-1;
				if(a[i-1][j-1]!=-1)a[i-1][j-1]++;
				if(a[i][j-1]!=-1)a[i][j-1]++;
				if(a[i-1][j]!=-1)a[i-1][j]++;
				if(a[i+1][j+1]!=-1)a[i+1][j+1]++;
				if(a[i-1][j+1]!=-1)a[i-1][j+1]++;
				if(a[i+1][j-1]!=-1)a[i+1][j-1]++;
				if(a[i][j+1]!=-1)a[i][j+1]++;
				if(a[i+1][j]!=-1)a[i+1][j]++;
			}
			}
			getchar();
		}
		printf("Field #%d:\n",c);
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=m;j++)
			{
				if(a[i][j]==-1)printf("*");
				else printf("%d",a[i][j]);
			}
			printf("\n");
		}
		printf("\n");
	}
 	return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版